Cache issue

Jan 28, 2011 at 6:49 AM

Dear Chris,

 

We are using config store on our prod farm and we have a config store at root site collection level and also at every site collection level.

The root site collection contains default key values which may be overridden at site collection level.

For some cases we notice that the values in the config store at the site collection level are being overlooked  and the value from root site collection is taken even though there exists value for the same key at site collection level. Have you noticed a problem like this before? the value seems to come from global cache and not local cache.

The app pools are recycled every night. Can it be an issue with cache? Please do provide your valuable inputs.

 

Regards,

Ramana

Coordinator
Jan 28, 2011 at 2:14 PM

@Ramana,

I haven't seen this behaviour, but would like to investigate this further with you to determine if there is a bug.

Have you tried enabling logging (or debugging) to see if there are any exceptions happening?

Thanks,

Chris.

P.S. Is there some way I can contact you directly? Perhaps send me a direct message through Codeplex, then we can exchange e-mail addresses.

Feb 1, 2011 at 5:30 AM

Dear Chris,

When the issue was first noticed I tried using Debug view on the front end server where this was happening and that is when I noticed that local config store value was not in cache and that the value was picked only from global config store. We recycled app pool (blank entry in web.config) to sort it out. As this is a production environment we dont have much time to troubleshoot.

you can reach me at ramana_16@hotmail.com

Thanks a lot for taking your time to help me out.

 

Regards,

Ramana